Search found 183 matches

by chilipalmer
Thu Nov 05, 2020 4:00 am
Forum: HELP ME!
Topic: No heat/no cold
Replies: 12
Views: 1306

No heat/no cold

YOG wrote: Wed Nov 04, 2020 11:17 pm https://www.facebook.com/pumabits
Thanks dude.
by chilipalmer
Wed Nov 04, 2020 10:45 pm
Forum: HELP ME!
Topic: No heat/no cold
Replies: 12
Views: 1306

No heat/no cold

Does he have a business e-mail that you can share? (I'm not in the UK).
by chilipalmer
Tue Nov 03, 2020 6:39 pm
Forum: HELP ME!
Topic: High revs on first cold start and not warming up.
Replies: 11
Views: 1337

High revs on first cold start and not warming up.

Have you tried cleaning the air intake temperature sensor?
by chilipalmer
Tue Nov 03, 2020 5:59 pm
Forum: HELP ME!
Topic: No heat/no cold
Replies: 12
Views: 1306

No heat/no cold

YOG, thanks for the input. I'm trying to find a kit to remove the a/c pipes but so far no luck. Since I'll need to change the resistor, does anyone know if one of those Chinese generics will do the trick? Went to the Ford dealership today and they wanted over 60 quid for one. I remember buying one y...
by chilipalmer
Mon Nov 02, 2020 11:49 pm
Forum: HELP ME!
Topic: No heat/no cold
Replies: 12
Views: 1306

No heat/no cold

The motor is placed under the pollen filter housing, is it not? Any idea if I can get to it without disconnecting a/c pipes?
by chilipalmer
Mon Nov 02, 2020 10:44 pm
Forum: HELP ME!
Topic: No heat/no cold
Replies: 12
Views: 1306

No heat/no cold

Ok, just checked the resistor and it's covered in rust. The connector has rust too. I tried to scrub some off, gave it a good clean with a metal contact cleaner but when I reassembled the lot it still didn't work. Then I looked behind the panel, under the radio, and there was 12V there. Any pointers...
by chilipalmer
Mon Nov 02, 2020 4:44 pm
Forum: HELP ME!
Topic: No heat/no cold
Replies: 12
Views: 1306

No heat/no cold

Thanks for replying, fella.

I haven't checked the voltage yet. I'll do that today as soon as I have some spare time.
When the front panel heater controllers go kaput, do they suddenly stop working or do they give out hints they are on the way out?
by chilipalmer
Sun Nov 01, 2020 9:32 pm
Forum: HELP ME!
Topic: No heat/no cold
Replies: 12
Views: 1306

No heat/no cold

Hi. The heater in my Puma always worked great. Today, out of the sudden, it stopped working. I get no heat nor cold. Nothing blows out of the vents. The lights for the A/C and air recirculation button work and so does the lighter. The panel lights also work. The HCV valve is genuine Ford and the ant...
by chilipalmer
Thu Nov 28, 2019 9:50 pm
Forum: HELP ME!
Topic: Airbag codes
Replies: 1
Views: 1728

Airbag codes

I've been having a lot of trouble diagnosing the reason why my airbag light doesn't come on when I start the car. I finally managed to connect it to a OBD2 diag. machine and these are the codes it found: B1932: Air Bag Driver Circuit Open B1877: Seat Belt Driver Pretensioner Circuit Open B1318: Batt...
by chilipalmer
Mon Nov 25, 2019 8:26 pm
Forum: HELP ME!
Topic: Windscreen brok
Replies: 3
Views: 1697

Windscreen brok

Try importing one from Spain. There's a spanish website which has loads of them. It's callled Mil Anuncios.
by chilipalmer
Sun Nov 24, 2019 3:14 am
Forum: HELP ME!
Topic: MOT fail questions
Replies: 5
Views: 2056

MOT fail questions

I took the clock panel apart. The bulbs are there. I also bought a cheapo diag tool but sadly it does not check for airbag problems.
by chilipalmer
Sat Nov 23, 2019 1:50 pm
Forum: HELP ME!
Topic: MOT fail questions
Replies: 5
Views: 2056

MOT fail questions

Thanks for the reply. I don't get the airbag light nor the engine check light...Car has very likely been tinkered with. I'll try to find a shop which has a diagnostic machine and see if it coughs up some codes.
by chilipalmer
Fri Nov 22, 2019 11:26 pm
Forum: HELP ME!
Topic: MOT fail questions
Replies: 5
Views: 2056

MOT fail questions

1- As I was having my little geriatric Puma inspected the low beam on the left side blew out (or so I thought). When I got back home I replaced the bulb still it wouldn't come on. Then I noticed the coating on the wires is totally rotten. I broke out a multimeter which attested the socket wasn't get...
by chilipalmer
Sun Jan 06, 2019 8:25 pm
Forum: HELP ME!
Topic: Excessive blow by?
Replies: 0
Views: 1383

Excessive blow by?

Hi. Is there a way to measure how much blow by is too much? Yesterday i was checking the oil level and decided to remove the oil cover while the car was running. It seemed like there was too much blow by coming from the engine. I left the cover rest over the hole and it "danced" a bit. Eng...
by chilipalmer
Mon Jan 15, 2018 4:01 pm
Forum: HELP ME!
Topic: part name / number
Replies: 8
Views: 2334

part name / number

Sadly I cannot take a pic now because the car is having some cosmetic work done in another shop... :?
by chilipalmer
Sun Jan 14, 2018 1:37 pm
Forum: HELP ME!
Topic: should there be any play in driveshaft?
Replies: 2
Views: 1053

should there be any play in driveshaft?

It does! I was hesitating between changing the cv joint or the whole axle. Given what you said I'm going with the cv joint alone. Many "havlas" mate.
by chilipalmer
Sat Jan 13, 2018 11:24 pm
Forum: HELP ME!
Topic: should there be any play in driveshaft?
Replies: 2
Views: 1053

should there be any play in driveshaft?

My car is undergoing major repairs and one of them concerns the offside drive shaft. The cv boot is torned, losing grease and now I hear some cracking noises coming from that area. I was planning on just replacing the joint but i noticed some minor play on the shaft. Is this normal?
by chilipalmer
Sat Jan 13, 2018 7:52 pm
Forum: HELP ME!
Topic: part name / number
Replies: 8
Views: 2334

part name / number

Thanks for the replies chaps. Cherry, I checked the link and it should be that part. Problem is when the mechanic showed it it looked like it was made from rubber alone. No metal. It was about 8 centimeters across. Wish I had access to the car to take a pic...
by chilipalmer
Sat Jan 13, 2018 2:33 pm
Forum: HELP ME!
Topic: part name / number
Replies: 8
Views: 2334

part name / number

I believe the part looks something like this.
by chilipalmer
Fri Jan 12, 2018 9:20 pm
Forum: HELP ME!
Topic: part name / number
Replies: 8
Views: 2334

part name / number

TOday I took my car to a mechanic who diagnosed a shagged gear box mounting. He showed it to me and I could see this part was like a block of rubber and had a gash across it. Its purpose is to keep the gear box from moving when you shift a gear. He could make the whole thing move by sticking a crowb...
by chilipalmer
Wed Dec 27, 2017 3:49 pm
Forum: HELP ME!
Topic: Knocking noise when depressing clutch pedal
Replies: 6
Views: 1882

Knocking noise when depressing clutch pedal

DOH wrote: rear lower Gearbox mounting
Pardon the silly question but is that the same thing as the rear engine torque link?
by chilipalmer
Tue Dec 26, 2017 11:25 pm
Forum: HELP ME!
Topic: Knocking noise when depressing clutch pedal
Replies: 6
Views: 1882

Knocking noise when depressing clutch pedal

tuonokid wrote: CV joint?? Does it do it more with lock on the steering?
Barry
CV joints was my initial suspicion (I even ordered a pair) as sometimes I did hear the noise with lock on steering but I'm able to reproduce the sound with a straight steering wheel and by merely pressing the clutch pedal.
by chilipalmer
Tue Dec 26, 2017 6:38 pm
Forum: HELP ME!
Topic: Knocking noise when depressing clutch pedal
Replies: 6
Views: 1882

Knocking noise when depressing clutch pedal

A few weeks ago I thought heard a thumping/knocking sound coming from my Puma's suspension. After further inspection I realized the noise is most likely coming from the transmission. Whenever I depress the clutch pedal, especially if the car is under load, I hear the noise. A few months back I repla...
by chilipalmer
Sat Dec 09, 2017 12:31 pm
Forum: HELP ME!
Topic: Thumping noise when turning the wheel
Replies: 4
Views: 1555

Thumping noise when turning the wheel

While checking the springs I noticed something strange: the rubber mountings are not in contact with the chassis! There's a small gap between the two. What could cause that? Old rubbish springs perhaps?
by chilipalmer
Fri Dec 08, 2017 2:42 pm
Forum: HELP ME!
Topic: Thumping noise when turning the wheel
Replies: 4
Views: 1555

Thumping noise when turning the wheel

I'm getting this thumping noise when I turn the wheel to the right at very low speeds. I only hear one thump and I feel it in the steering column (doesn't appear to be happening at higher speeds or when the car is stationary) . It seems to be coming somewhere from the right wheel area. I've changed ...

Go to advanced search