No Dash Lights and Rear Lights

URGENT ASSISTANCE REQUIRED!

Moderator: Moderators

jim1980
Newbie
Newbie
Posts: 5
Joined: Tue Nov 09, 2010 4:12 pm
Model: 1.7

No Dash Lights and Rear Lights

Postby jim1980 » Tue Nov 09, 2010 4:24 pm

Girlfriends Puma has developed a fault where if you turn on the lights, the front lights come on and so does the clock light and radio light but all other lights on the dash/behind the buttons do not come on, also the rear lights do not come on.
Her brake lights work so does the fog and the side, normal and high beam front lights. Also the indicator lights both outside and on the dash work.
The buttons do actually work when you switch them on (eg heated rear screen) but no lights in the dash/behind the buttons/rear lights.

She states that sometimes when driving the dash lights do come on but i do not know if this also means her rear lights come on. Ive given the dash a whack and wiggled the light stalk about like crazy just incase its a lose connection when its happened to me and nothing has come back on. Very odd!

Any hints or tips would be appreciated. Winter is here now and ive told her not to drive it at night due to this issue.
0 x

User avatar
Dal
Site Administrator
Site Administrator
Posts: 14572
Joined: Wed Oct 03, 2007 8:27 pm
Model: Other

Re: No Dash Lights and Rear Lights

Postby Dal » Tue Nov 09, 2010 4:27 pm

When my rear lights didn't work once, spraying some switch cleaner on the rotary part of the "lights on" stalk cleaned the contacts inside and made the appropriate contacts for them to work again. Worth a go.
0 x

plezz
Adolescent
Adolescent
Posts: 31
Joined: Sat Sep 04, 2010 2:22 pm
Model: 1.7
Location: Romford
Contact:

Re: No Dash Lights and Rear Lights

Postby plezz » Wed Nov 10, 2010 12:03 am

Hi Jim, this is EXACTLY the same problem i've got at the mo with my wife's puma as well. the handbrake light seems to work, and so do the exterior lights, but the lights on the heater control, the radio and the speedo doesnt light up.

I've been told to take a look at the fuses, as it could be a duff fuse somewhere. someone on here mentioned fuses 6 and 2 if that helps.

can you post what works for you, as i wont have a chance to take a proper look untill the weekend, and would love to know what the cause is.

ta

Plezz
0 x

jim1980
Newbie
Newbie
Posts: 5
Joined: Tue Nov 09, 2010 4:12 pm
Model: 1.7

Re: No Dash Lights and Rear Lights

Postby jim1980 » Wed Nov 10, 2010 9:40 am

I was thinking it could be a fuse and did read your post. Problem is gf says sometimes it comes back on, if it was a fuse it wouldnt come back on would it? Ill check anyway and also clean any contacts on the stalk.
Next question is how do i get the stalk off?
0 x

User avatar
Cherie
Site Moderator
Site Moderator
Posts: 3942
Joined: Wed Oct 03, 2007 8:35 pm
Model: Other
Contact:

Re: No Dash Lights and Rear Lights

Postby Cherie » Wed Nov 10, 2010 9:42 am

As I've said in Plezz's thread, and Dal has said above, spray something like WD40 on the bit that you turn, and work it in. If it's the contacts that are dry, that will cure it!
0 x

plezz
Adolescent
Adolescent
Posts: 31
Joined: Sat Sep 04, 2010 2:22 pm
Model: 1.7
Location: Romford
Contact:

Re: No Dash Lights and Rear Lights

Postby plezz » Wed Nov 10, 2010 11:05 am

I'll give some WD40 a try on mine as well Dal. i dont doubt for a second you know what your talking about, but logically i would have thought the contacts are ok with mine as the exterior lights come on etc when i turn the stalk to the first and second position. its as if the stalk is making the connections needed to turn on the exterior lights, but the dashlights inside the car are not. plus the fact my heater only blows cold, and i've got one or two blown bulbs on the outside, make me think its a fuse. But i'll def give it a go though if the fuses look ok.
0 x

jim1980
Newbie
Newbie
Posts: 5
Joined: Tue Nov 09, 2010 4:12 pm
Model: 1.7

Re: No Dash Lights and Rear Lights

Postby jim1980 » Thu Nov 11, 2010 9:29 am

Ill give the WD40 a go and also check my fuses.
Plezz let me know how you get on.
0 x

plezz
Adolescent
Adolescent
Posts: 31
Joined: Sat Sep 04, 2010 2:22 pm
Model: 1.7
Location: Romford
Contact:

Re: No Dash Lights and Rear Lights

Postby plezz » Thu Nov 11, 2010 2:41 pm

Hi Jim, just letting you know how i got on - i replaced the blown fuse (number 6) and the replacement blew as soon as i turned the stalk!! so i need to invetigate why the fuses keep blowing..
i also forgot to turn the lights off when i went to get some new fuses, so now i have to go get some jump leads after work, jump start the car, find the radio codes as i dont have them, and hope the dead battery doesnt do anything to the immobiliser, or im well and truely stuffed lol.

i might go through both fuse boxes and check everyone for blow outs.

so far not good....
0 x

jim1980
Newbie
Newbie
Posts: 5
Joined: Tue Nov 09, 2010 4:12 pm
Model: 1.7

Re: No Dash Lights and Rear Lights

Postby jim1980 » Fri Nov 12, 2010 10:17 am

Cheers mate, ill check my fuses this weekend and also spray the stalk and ill let you know how i get on.
If and when you sort yours out if you could let me know how you get in id appreciate that.
0 x

jim1980
Newbie
Newbie
Posts: 5
Joined: Tue Nov 09, 2010 4:12 pm
Model: 1.7

Re: No Dash Lights and Rear Lights

Postby jim1980 » Mon Nov 15, 2010 11:13 am

Fixed the issue at the weekend, it wasnt a fuse but a dodgy indicator/light stalk, gave it a few whacks and it came back on, so sprayed it with GT85/WD40 and it seems to have fixed the issue.
0 x

User avatar
Dal
Site Administrator
Site Administrator
Posts: 14572
Joined: Wed Oct 03, 2007 8:27 pm
Model: Other

Re: No Dash Lights and Rear Lights

Postby Dal » Mon Nov 15, 2010 11:30 am

:thumbs:
0 x

ru55ell32
Newbie
Newbie
Posts: 1
Joined: Sat Dec 04, 2010 2:10 pm
Model: 1.7

Re: No Dash Lights and Rear Lights

Postby ru55ell32 » Wed Dec 08, 2010 8:41 pm

After months of arcing the 2 wires at the connector to get the lights to come on, I tried WD40 and now working... Thanks so much. Fords wanted £132 for replacement stalk unit. With MOT in January i'm very happy.
0 x

User avatar
Dal
Site Administrator
Site Administrator
Posts: 14572
Joined: Wed Oct 03, 2007 8:27 pm
Model: Other

Re: No Dash Lights and Rear Lights

Postby Dal » Wed Dec 08, 2010 8:42 pm

Glad ProjectPuma has been of help and saved you a few £

:D
0 x

Krheigh
Newbie
Newbie
Posts: 1
Joined: Sun Jul 30, 2017 7:54 pm
Model: Black

No Dash Lights and Rear Lights

Postby Krheigh » Sun Jul 30, 2017 8:01 pm

Hi im new here and had this problem. Now I would like to share what my problem was... I mounted a new car stereo and the illumination cable (orange one in ISO adapter) is not used for my stereo. when I put power on orange cable all lights up just fine

I know it's a old thread but...
0 x


Return to “HELP ME!”

Who is online

Users browsing this forum: No registered users and 26 guests