Revs linger

URGENT ASSISTANCE REQUIRED!

Moderator: Moderators

Post Reply
User avatar
Roary
Adolescent
Adolescent
Posts: 49
Joined: Sun Jan 03, 2010 6:31 pm
Model: 1.7
Location: london

Revs linger

Post by Roary »

Hi
Has anyone any ideas why my Puma is starting to rev high when I come to a stop. If I touch the pedal a bit or put the car back in gear and let the clutch up a bit it returns to normal. Thanks.
0 x
st220kyle
Adolescent
Adolescent
Posts: 132
Joined: Sat Feb 16, 2019 11:06 pm
Model: 1.7

Revs linger

Post by st220kyle »

Faulty Idle control valve
2 x
User avatar
red
Site Administrator
Site Administrator
Posts: 11498
Joined: Wed Oct 03, 2007 4:31 pm
Model: Other
Location: Cambridgeshire
Contact:

Revs linger

Post by red »

Clutch position switch maybe? Check under the pedal that it hasn't become dislodged or damaged.
0 x
FRP#0201 (2000) 2009-2011
Melina Blue (1999) 2006-2009
Moondust Silver (2000) 2006
User avatar
Lorenzo Zaga
Adolescent
Adolescent
Posts: 46
Joined: Tue Jun 01, 2021 8:14 pm
Model: 1.7

Revs linger

Post by Lorenzo Zaga »

hi, try t check the MAF, in my puma when it was dirty, when i was stopped, the idle it was not linear and go up and down.
0 x
User avatar
Roary
Adolescent
Adolescent
Posts: 49
Joined: Sun Jan 03, 2010 6:31 pm
Model: 1.7
Location: london

Revs linger

Post by Roary »

Thanks people...I will check these things out.
0 x
Gasher33
Project Teen!
Project Teen!
Posts: 18
Joined: Sat Feb 11, 2017 4:25 pm
Model: 1.7

Revs linger

Post by Gasher33 »

As a last instance check the TPS and the wiring. Had this problem with mine and it was the wiring to the TPS. To check it try disconnecting the TPS and see if it is better
0 x
SleepyDawg
Adolescent
Adolescent
Posts: 20
Joined: Mon Apr 19, 2021 9:17 pm
Model: 1.4

Revs linger

Post by SleepyDawg »

Roary wrote: Wed Jun 30, 2021 7:49 pm Hi
Has anyone any ideas why my Puma is starting to rev high when I come to a stop. If I touch the pedal a bit or put the car back in gear and let the clutch up a bit it returns to normal. Thanks.
I had the same problem. Like st220kyle said, it's the Idle control valve which gets dirty. I didn't even replace mine, just cleaned it with MAF cleaner and let it dry for a while. Never had the problem again.
0 x
Post Reply

Return to “HELP ME!”