heater hassle

URGENT ASSISTANCE REQUIRED!

Moderator: Moderators

Post Reply
kinkyfreestyler
Newbie
Newbie
Posts: 6
Joined: Sat Dec 16, 2017 11:14 pm
Model: 1.7

heater hassle

Post by kinkyfreestyler » Tue Sep 25, 2018 12:16 am

Hi recently changed my heater control valve and the heater is still blowing only cold ? any ideas ?

thanks
0 x

User avatar
tuonokid
Project Elder
Project Elder
Posts: 3644
Joined: Fri Nov 23, 2012 8:41 pm
Model: 1.7
Location: Huddersfield

heater hassle

Post by tuonokid » Tue Sep 25, 2018 12:47 am

Hi Mate
Possibly a cheapo ebay HCV. The genuine Ford one is the only one that works and lasts. The only other thing it could be is the heater control panel but still more likely to be the HCV.
0 x
2001 ColOrado red Puma 1.7, work in progress.
Westfield SEIW 1800 Zetec.
Building Westfield SEI 2.0 Zetec Blacktop on TBs.
Fiesta Style 1.25
Aprilia Tuono Factory.
1975 Yamaha TY80
Now working on my sons Anglia 105e

My Project Link - http://www.projectpuma.com/viewtopic.php?f=64&t=23509" onclick="window.open(this.href);return false;

User avatar
Van_Dammesque
Project Regular
Project Regular
Posts: 350
Joined: Sun Dec 11, 2011 7:54 pm
Model: 1.7

heater hassle

Post by Van_Dammesque » Tue Sep 25, 2018 9:37 am

Bled the system fully?
Is the water agitating when the engine is on? (beware hot water!!!!)
0 x
Image

User avatar
Dal
Site Administrator
Site Administrator
Posts: 14698
Joined: Wed Oct 03, 2007 8:27 pm
Model: Other

heater hassle

Post by Dal » Tue Sep 25, 2018 11:56 am

Also make sure the electrical contacts from the HCV are actually connecting the cars wiring loom. Squeeze them together a bit to ensure connection. I had that once and it was infuriating.
0 x

Post Reply

Return to “HELP ME!”