Sand's "greenland" 1.7 VCT

Do you have a Puma that is a project? Do you want to track the progress with your own thread? Feel free to do it here.

Moderator: Moderators

SandStorm
Adolescent
Adolescent
Posts: 52
Joined: Mon Aug 15, 2016 9:47 pm
Model: 1.7

Sand's "greenland" 1.7 VCT

Postby SandStorm » Thu Feb 16, 2017 2:13 am

While I'm waiting for my new dash buttons and cluck in blue, already did a mini-mod.

Image

Heater panel in blue. T5 flat head leds. I had to do the inversion of the little legs because in the original position (same as standart bulbs) it wouldn't lit up.

Image

Now, a question... What kind of bulb the speedometer uses?
Still a T5, or is another? Because the lamp housing (i haven't removed it, only peeked up) seems way bigger than those on warning lights and heater panel.
1 x

SandStorm
Adolescent
Adolescent
Posts: 52
Joined: Mon Aug 15, 2016 9:47 pm
Model: 1.7

Sand's "greenland" 1.7 VCT

Postby SandStorm » Fri Feb 17, 2017 3:26 am

Ok, was like this:

Image

Why I say "was"?
Because when I turn the demister or the rear fog light, the warning lamp is too bight. Way too bright and I get blinded.
So, I reverted everything to green except the clock, because This clock is easily readable at night.

Image

I'll use the blue heater panel leds on my scooter, instead xD
1 x

SandStorm
Adolescent
Adolescent
Posts: 52
Joined: Mon Aug 15, 2016 9:47 pm
Model: 1.7

Sand's "greenland" 1.7 VCT

Postby SandStorm » Tue Mar 21, 2017 8:04 pm

I've been spending time with my Gilera scooter, the little one stopped working, so I ordered a bunch of needed parts for the economic summer 2 wheeled ride.
No matter to say, the scoot is now running and today I did some small TLC on my Bullet.

Before:

Image

After:

Image

I've polished the rear fog lights.
1 x

SandStorm
Adolescent
Adolescent
Posts: 52
Joined: Mon Aug 15, 2016 9:47 pm
Model: 1.7

Sand's "greenland" 1.7 VCT

Postby SandStorm » Fri Apr 07, 2017 11:38 am

So, this time for some reason, my key fob (IrDA) stopped working.
Then, discovered the car had alarm when it would activate when i opened the door or put the engine running.
Something did messed up. So, i disconnected car battery and removed the keys batteries too.
connected everything again, was unable to program the key. Then later, maybe after an hour or more, was able to program it, and solved my issues. All works again. But now I know the car does have an alarm, because i didnt knew. :lol:

Well, today I did some care to my Bullet, so... Decided to buy better quality leather for the steering wheel, and this time did it all around.

Image

Image

I like the results. :)
0 x

SandStorm
Adolescent
Adolescent
Posts: 52
Joined: Mon Aug 15, 2016 9:47 pm
Model: 1.7

Sand's "greenland" 1.7 VCT

Postby SandStorm » Wed Sep 20, 2017 5:55 pm

Been a while since my last post.
So, in the meantime I had my rear shoes replaced.

Even If nowadays I notice the brake very stiff if the car sits for hours. Some vacuum leak somewhere.
And also sometimes vibrates a bit when braking, I suspect the problem is the rear drum.

Anyways, did some interior mods with this:

Image

Image

Image


Also replaced my air vents because they were broken and fitted these:

Image

Replaced my homemade buttons surround fix with a good looking piece too.
Went to MOT:

Image

And passed with only advisories for oil leaks.
1 x

SandStorm
Adolescent
Adolescent
Posts: 52
Joined: Mon Aug 15, 2016 9:47 pm
Model: 1.7

Sand's "greenland" 1.7 VCT

Postby SandStorm » Wed Oct 18, 2017 3:15 pm

Been having the P0443 error since I bought this car, but today I sorted it out. Simply replaced that evap valve. 96FB-9C915

Image

Image

Image
0 x


Return to “ProjectPuma”

Who is online

Users browsing this forum: mada, mogsa98, Yahoo [Bot] and 51 guests