Sand's "greenland" 1.7 VCT

Do you have a Puma that is a project? Do you want to track the progress with your own thread? Feel free to do it here.

Moderator: Moderators

SandStorm
Adolescent
Adolescent
Posts: 66
Joined: Mon Aug 15, 2016 9:47 pm
Model: 1.7

Sand's "greenland" 1.7 VCT

Postby SandStorm » Thu Feb 16, 2017 2:13 am

While I'm waiting for my new dash buttons and cluck in blue, already did a mini-mod.

Image

Heater panel in blue. T5 flat head leds. I had to do the inversion of the little legs because in the original position (same as standart bulbs) it wouldn't lit up.

Image

Now, a question... What kind of bulb the speedometer uses?
Still a T5, or is another? Because the lamp housing (i haven't removed it, only peeked up) seems way bigger than those on warning lights and heater panel.
1 x

SandStorm
Adolescent
Adolescent
Posts: 66
Joined: Mon Aug 15, 2016 9:47 pm
Model: 1.7

Sand's "greenland" 1.7 VCT

Postby SandStorm » Fri Feb 17, 2017 3:26 am

Ok, was like this:

Image

Why I say "was"?
Because when I turn the demister or the rear fog light, the warning lamp is too bight. Way too bright and I get blinded.
So, I reverted everything to green except the clock, because This clock is easily readable at night.

Image

I'll use the blue heater panel leds on my scooter, instead xD
1 x

SandStorm
Adolescent
Adolescent
Posts: 66
Joined: Mon Aug 15, 2016 9:47 pm
Model: 1.7

Sand's "greenland" 1.7 VCT

Postby SandStorm » Tue Mar 21, 2017 8:04 pm

I've been spending time with my Gilera scooter, the little one stopped working, so I ordered a bunch of needed parts for the economic summer 2 wheeled ride.
No matter to say, the scoot is now running and today I did some small TLC on my Bullet.

Before:

Image

After:

Image

I've polished the rear fog lights.
1 x

SandStorm
Adolescent
Adolescent
Posts: 66
Joined: Mon Aug 15, 2016 9:47 pm
Model: 1.7

Sand's "greenland" 1.7 VCT

Postby SandStorm » Fri Apr 07, 2017 11:38 am

So, this time for some reason, my key fob (IrDA) stopped working.
Then, discovered the car had alarm when it would activate when i opened the door or put the engine running.
Something did messed up. So, i disconnected car battery and removed the keys batteries too.
connected everything again, was unable to program the key. Then later, maybe after an hour or more, was able to program it, and solved my issues. All works again. But now I know the car does have an alarm, because i didnt knew. :lol:

Well, today I did some care to my Bullet, so... Decided to buy better quality leather for the steering wheel, and this time did it all around.

Image

Image

I like the results. :)
0 x

SandStorm
Adolescent
Adolescent
Posts: 66
Joined: Mon Aug 15, 2016 9:47 pm
Model: 1.7

Sand's "greenland" 1.7 VCT

Postby SandStorm » Wed Sep 20, 2017 5:55 pm

Been a while since my last post.
So, in the meantime I had my rear shoes replaced.

Even If nowadays I notice the brake very stiff if the car sits for hours. Some vacuum leak somewhere.
And also sometimes vibrates a bit when braking, I suspect the problem is the rear drum.

Anyways, did some interior mods with this:

Image

Image

Image


Also replaced my air vents because they were broken and fitted these:

Image

Replaced my homemade buttons surround fix with a good looking piece too.
Went to MOT:

Image

And passed with only advisories for oil leaks.
1 x

SandStorm
Adolescent
Adolescent
Posts: 66
Joined: Mon Aug 15, 2016 9:47 pm
Model: 1.7

Sand's "greenland" 1.7 VCT

Postby SandStorm » Wed Oct 18, 2017 3:15 pm

Been having the P0443 error since I bought this car, but today I sorted it out. Simply replaced that evap valve. 96FB-9C915

Image

Image

Image
0 x

SandStorm
Adolescent
Adolescent
Posts: 66
Joined: Mon Aug 15, 2016 9:47 pm
Model: 1.7

Sand's "greenland" 1.7 VCT

Postby SandStorm » Tue Nov 28, 2017 8:55 pm

this arrived on my mail yesterday:

Image

Image
0 x

SandStorm
Adolescent
Adolescent
Posts: 66
Joined: Mon Aug 15, 2016 9:47 pm
Model: 1.7

Sand's "greenland" 1.7 VCT

Postby SandStorm » Sat Jan 27, 2018 4:26 am

Polished my headlights.

Image

Image

Image

Image

And replaced the gasket. What a mess I found... The old one wasn't fit properly, was bent on the little "finger" in the top left corner, near the belt cover.
I've put a bit of sealant too (after properly degreasing)

Then left it cure. Tomorrow I'll start her up and check.

Image

Image

Image

Image
1 x

SandStorm
Adolescent
Adolescent
Posts: 66
Joined: Mon Aug 15, 2016 9:47 pm
Model: 1.7

Sand's "greenland" 1.7 VCT

Postby SandStorm » Mon Mar 26, 2018 10:58 pm

My powerdisk arrived today :)
Also, not in this photo, it's 2 abs sensors

Image
1 x

FastLee
Adolescent
Adolescent
Posts: 38
Joined: Wed Dec 20, 2017 9:02 pm
Model: 1.7
Location: Lisbon, Portugal

Sand's "greenland" 1.7 VCT

Postby FastLee » Tue Mar 27, 2018 7:46 pm

Good choice, I am seriously thinking about ordering those for my Puma.
Had those in a Saxo VTS(Cup) years ago and they were fine. Had Brembo Max in a 106 Rallye and did not like them.
1 x
1998 Ford Puma 1.7 VCT
2002 Volvo S60 T5
1999 Citroen Berlingo Multispace 1.4i

SandStorm
Adolescent
Adolescent
Posts: 66
Joined: Mon Aug 15, 2016 9:47 pm
Model: 1.7

Sand's "greenland" 1.7 VCT

Postby SandStorm » Wed Mar 28, 2018 9:27 pm

All installed, was a pain in the rear about how tight everything was.
But in the end, managed it.
Still... Tomorrow will undo one of them, since I forgot one washer from the caliper...
About the abs. Even with new sensors, still not working :(
Will check it again. And maybe put the old ones back since they were really dirty
0 x

SandStorm
Adolescent
Adolescent
Posts: 66
Joined: Mon Aug 15, 2016 9:47 pm
Model: 1.7

Sand's "greenland" 1.7 VCT

Postby SandStorm » Fri Apr 20, 2018 8:51 pm

Car is in the garage.
After a proper look, several issues were detected.
Ordered two original transm seals.
And why my abs didn't worked, wasn't because of faulty sensor.
It was because the pump was removed.
Also, the car suffered one AC delete. By getting the compressor removed.
I don't know why the previous owners did this.
Why. Why there are people like that.
AC is basically mandatory in the summer here in portugal with spikes of 35, 40ºC in the summer...
There are other issues too. Like the rear shocks. They converted eye socket shocks to fork. By... Soldering a fork ending.
I don't know if I continue this project or if I give up.
Sorry for the rant, but I have two other fords. A Fiesta I bought almost new in 2005 and care it like a baby.
And a Ford Orion that never gave me issues like this...
0 x


Return to “ProjectPuma”

Who is online

Users browsing this forum: alex', JAC, Majestic-12 [Bot], red and 93 guests